Require Eclipse 4.2 (2)
Oskar’s fix in https://yellowgrass.org/issue/Spoofax/713 requires Eclipse 3.8 and Vlad’s fix for the side-by-side changes in Eclipse 4.2 introduced some code for supporting legacy Eclipse versions. If we require Eclipse 4.2 we can implement Oskar’s fix and get rid of the legacy side-by-side editor code.
The question is, do people still use Eclipse 3.7 or do you think we can require Eclipse 4.2?Submitted by Gabriël Konat on 14 August 2013 at 01:01
Remark: 3.7 classic is still the recommended version according to http://metaborg.org/wiki/spoofax/download
As long as there is an explicit dependency or in-IDE message about 3.8 or 4.2 being required, I think it’s acceptable to require a newer version. In the past supporting older versions was never much of an issue, but it also isn’t all that important. Note that 3.8 is a bit of a weird version: it was released alongside 4.2 but most developer packages are only available in version 3.7 or 4.2. If 3.x support is desired, 3.7 may be the better version to support.
3.8 has the advantage when we look at maintainability. They stated that the 4 serie would be backwards compatible with 3.8.
Choosing 3.7 might introduce new bugs on software when we actualy want/ need to switch to 4
In addition it is nice that users are able to use both 3 and 4
Is there a distribution of 3.8 where it will just work, like Eclipse 3.7 Classic above? Then 3.8 could work.
We don’t want to support 3.7 because that would not give us any maintainability benefits. There is an ‘Eclipse classic’ distribution for 3.8, but it was never publicly visible, 4.2 (Juno) is the version visible to the public. Eclipse 4.2 has been available for over a year now (since 27 June 2012) so I’d say we can switch to it.
I agree. We don’t have such a large userbase that we need to worry about Eclipse backwards compatibility. (Theoretically, there could be users who need some older version of Eclipse for other plugins and this upgrade would make that incompatible with Spoofax, but I don’t think we need to worry about that.)
@Eelco you’re absolutely right. That kind of backward compatibility was never very important. And 3.8 seems so awkward that I wouldn’t bother supporting that. But fwiw, if you’d want 3.x support, 3.7 seems a better target.
I agree with 4.x as well. We will need a big banner on the website (and maybe an email) stating the new requirement as users will no longer be able to update via the update site unless they meet the version requirement.
But it is not as if we have the resources to maintain backwards compatibility. So, if 4.x is not broken / does not break Spoofax (or we can fix the brokenness), I’d say let’s drop 3.x.
Ok, I’ve changed it from a question to a task :)
The buildfarm now builds against Eclipse Classic 4.2.2 and the feature requires version 3.8.0 of org.eclipse.core.runtime and org.eclipse.jdt.core, preventing an installation on Eclipse 3.7 or older. The legacy sidebyside editor project has been removed since we no longer need to support Eclipse 3.7 or older. Oskar’s fix in https://yellowgrass.org/issue/Spoofax/713 can now be applied.
I updated the download page.
Log in to post comments