"We recommend the Eclipse 4.2 classic distribution"?
The Spoofax download page
we recommend the Eclipse 4.2 classic distribution
Is that still up-to-date?Submitted by Eelco Visser on 24 June 2014 at 23:36
I think it makes more sense to change this to the latest stable distribution (= 4.3.2 / Kepler).
To my knowledge, all Spoofax features work on 4.2.x and 4.3.x.
I’m running on 4.3.2 which seems fine.
Also, it still seems to be a common error that people use JRE 6 instead of JRE 7 (or 8) and don’t understand why things don’t work.
Even if they’ve installed JRE 7, it may still be the case that JRE 6 is installed next to it, and I believe Eclipse may still pick JRE 6 in such a case (depending on whether it’s set to the default JRE and whether Eclipse was installed before or after JRE 7 was installed).
I think optimally the “Spoofax Configuration Warning” should warn when Eclipse uses JRE <= 6. In the meantime, it may be good to add this to the download page:
In Eclipse, make sure that the JDK compliance level is set to 1.7 or higher (Window -> Preferences -> Java -> Compiler -> Compiler compliance level).
We should recommend 4.3 indeed. Actually Eclipse 4.4 will be released today and according to the porting notes we should be compatible, so we could probably recommend Eclipse 4.4 even.
We shouldn’t recommend 4.4 before it has been tested.
Can you (Oskar, Gabriël) update the download page? Including the JRE configuration information.
I installed JRE 8, but Eclipse still asked for JRE 6 and proposed to install it. After that it is not clear which JRE it is using, so that information is quite useful.
Duh :) It’s not Eclipse that asks for JRE 6, it’s OSX that wants to install it because it does not see the Oracle JRE. Eclipse should still run using the installed Oracle JRE.
I updated the download page. Closing the issue…
I changed the recommended Eclipse version to Luna (4.4) now. I’ve been using Luna over the past two weeks and everything seems to work correctly.
Log in to post comments